Lead

Apr 22 12 11:32 AM

Tags : :

Ok - I give up-
I can't get the SINT024BTFT to auto-initialise! I can program the registers, turn on/off back light etc but the auto-initialise just doesn't seem to work. [The SINT018ATFT seems to fire-up just fine. I can program in all the graphics etc no problem.]
I've tried initialising from my code using the example in the RA8872 manual as reference. No Joy. I'm working with 2 of these and both behave the same.
Anybody else having this problem? Who can I speak to for help? - failing that can I have my money back?
Frustrated
Pete

Quote    Reply   

#1 [url]

Apr 25 12 9:29 PM

Hi Pete,
Sorry for your frustration.  Do you have all of the documentation for the SINT024BTFT?  Please PM me your email address and I can send you our init code for this part.  I have attached the schematic to this reply, also.

Let me know how we can help!  Please also feel free to post your schematic and code and I will have it reviewed by our engineers.

Thanks,
Terry


Click here to view the attachment

Quote    Reply   

#4 [url]

Apr 26 12 1:52 PM

Pete

Having the same problem with SINT022 I believe. Please let me know if you get anywhere. I gave up in fustration a while back. Could read/write to registers, and adjust backlight just couldn't get any graphics to work!

Jack

Quote    Reply   

#7 [url]

May 2 12 7:14 AM

Hi,
Working with these devices I've discovered a few things. If you power-up with nothing connected except a 10k pull-up on pin8 (/rd) it should initialise ok. You can tell because the screen goes from black to bright then black again - but the back-light near the screen connector ribbon should be lit. If this doesn't happen ie screen is grey or no back-light it hasn't initialised. Ok so far, so good.
Now with my system (z80F91 processor) with everything attached- data lines and cs, rd, wr, rs - I found it wouldn't auto initialise. As with Jack's problem above ie read/write registers etc but no graphics. However, remove cs (z80F91 A0) and it fired up no problem (although unable to program now, obviously). By isolating cs/a0 with a transitor which is turned on after auto-initialisation (via a z80F91 gpio line) all works perfectly! Although this was progress I really wanted to be able to initialise the device from my own code and be fully in control.
Terry sent me the auto-initialise code which has been very useful. I wrote an assembler version of ILI9341_init and bloody hell! it works. To prove it I've now removed the transistor and allowed it to fail initialisation on-power up. With a command I reset the RA8872, set the registers as in the data sheet and invoke ILI9341_init and it works! No need for on-board auto-initialisation....
Hope this helps
Cheers
Pete

Quote    Reply   

#8 [url]

Oct 6 12 6:36 PM

Hello All

I have just brought a SINT022ATFT LCD Module for my Amateur Radio project, and I have finarly got it to work (well I have it displaying stuff) but using the on board auto-initialiser but would also like for my PIC Microcontroller to handle all the initialising and everything.
So if all possible I would also like to get a copy of the auto-initialiser code if its at all possible.

Thanks

Paul


Quote    Reply   

#10 [url]

Oct 29 12 9:18 AM

I've been having similar problems with the auto initialise function. If I set my RD pin as an input with pullup on MCU startup the screen normally initialises itself (but sometimes this fails, perhaps a consequence of the power supply being only 2.9v, I need to check this).

I used my logic analyser to check what the auto initialisation was doing, it sets these registers:
Register value

0x10 0x08

0x04 0x00
0x21 0x10

0x11 0x00
0x12 0x00
0x13 0x00
0x14 0x27
0x15 0x05
0x16 0x05
0x17 0x00
0x18 0x00
0x19 0xEF
0x1A 0x00
0x1B 0x00
0x1C 0x02
0x1D 0x02
0x1E 0x00
0x1F 0x08
0x20 0x01
0x40 0x0C
0x8A 0x84
0x8B 0xF0

Then delays for a bit and sends loads and loads of writes to register 0x13 which appears to be bitbanging the GPIOs. No idea why.

There has been talk in this thread about manually initialising the ILI9340. Does anyone have any more details? can the auto-initialisation chip be disabled somehow other than modifying the module?

Quote    Reply   

#11 [url]

Nov 19 12 1:37 PM

Have you been able to get the board to work properly?

If not, do ensure that the voltage (and reset pin!) are held at the required 3.3v for the entirety of the start-up sequence.

Also, ensure that no writes on the parallel bus occur before the startup has completed.

Auto-initialization is not disable-able and will occur at every power-up of the INT board.

99% of problems relating to startup of the INT boards are due to premature writes on the parallel bus or a reset line that is not held high at power-up.

Hope that helps!

Quote    Reply   

#12 [url]

Nov 20 12 4:13 AM

Yes I got there eventually, peterk505 was kind enough to send me the ILI9340 initialisation code which I now perform on startup and it works every time!

I'm now having problems with orientation, is the RA8872 able to operate the display in portrait mode? I'd like to be able to use its built in text rendering with the screen rotated

Quote    Reply   

#13 [url]

Nov 20 12 10:00 AM

Hi trsaunders-

You'll want to look into using the DPCR, HDWR, VDHR0 and VDHR1 registers (rotation, horizontal width, vertical width0 and 1, respectively).  These are all well documented in the RA8872's manual, but you'll be most interested in sending a 90 degree rotation command to the DPCR.  This should allow you to use the built-in text functionality as well.

Hope that helps!
-Allan

Quote    Reply   

#14 [url]

Nov 21 12 4:32 AM


Hi Allan,

thanks for the tip, I'll try that out, I hadn't previously updated HDWR and VDHR as I thought they were constant dimensions of the screen the RA8872 is driving. Once the screen is rotated using DPCR are all coordinates now in the rotated screen coordinate space?

Quote    Reply   

#15 [url]

Nov 21 12 10:10 AM

I believe using the DPCR only should do the trick, however if you end up with a section of the screen that is not being drawn you'll want to look into adjusting the screen size.  Also, if the screen ends up mirrored (text being written backwards or upside-down) you'll want to look into the HDIR and VDIR registers to flip the memory writing directions.

Good luck!
-Allan

Quote    Reply   

#16 [url]

Mar 13 14 3:31 PM

what is the ILI9340 initialisation code? can somebody send me this code please?
I tryed to use the demo program in the Ra8872 datasheet but display don't work, I can set the PWM but the display is always white....

Can somebody give me an advice?
thanks Daniele

Quote    Reply   

#17 [url]

May 9 14 8:55 AM

cannot get display started - having similar problems

Hi,

I am starting a project with an INT024BTFT and RA8872 controller.  I seem to be in the same position as a number of earlier posters.  I can change the backlight setting, and can read and write the contol registers, but I cannot get anything to display.

I have tried the code in the back of the RA8872 manual, but that does not seem to work for me.

If anyone has some other start-up code, I would like to see it.  I am using the 8080-mode interface, from a PIC32 micro.

Thanks for any help/advice

John
 

Quote    Reply   

#18 [url]

May 13 14 2:46 PM

RA8872 problems.....

I resolved my problems.....
I changed display, after some days without results I abbandoned the display with Ra8872, now I'm used a display  4d System

Quote    Reply   
Add Reply

Quick Reply

bbcode help